GoJack - SMS gratis

  • Dicembre 06, 2019, 06:41:08 pm
  • Benvenuto, Visitatore
Effettua l'accesso o una nuova registrazione.

Inserisci il nome utente, la password e la durata della sessione.
Ricerca avanzata  
Pagine: 1 ... 3 4 [5] 6 7 ... 9   Vai giù

Autore Topic: E fu cosi che arrivò anche la prima versione Web/Wap  (Letto 80007 volte)

0 Utenti e 5 Visitatori stanno visualizzando questo topic.

Daniele8787

  • Sviluppatore GoJack
  • Administrator
  • Senior
  • *****
  • Karma: +95/-0
  • Offline Offline
  • Post: 1875
  • L'unica vera libertà, corrisponde al non aver bisogno di NULLA.
    • Mostra profilo
Re:E fu cosi che arrivò anche la prima versione Web/Wap
« Risposta #60 il: Aprile 16, 2012, 08:17:04 pm »

Che server usi? è strano perchè tutore91 dice che o2 gli funziona.

??? ma poi scusa, se dici che o2 non consegna gli sms, come fai a dire che non invia bene le accentate? se l'sms non arriva allora come fai a saperlo scusa?

per quanto riguarda il problema della scelta del servizio che quando premi sulla select dei servizi ti fa la selezione da solo misteriosamente, davvero non so cosa dire. ???

ah e poi, visto che è un problema grafico: che browser usi?
« Ultima modifica: Aprile 16, 2012, 08:22:30 pm da Daniele8787 »
Connesso

drjis

  • GoJack tester
  • User quarto livello
  • *****
  • Karma: +15/-0
  • Offline Offline
  • Post: 485
    • Mostra profilo
Re:E fu cosi che arrivò anche la prima versione Web/Wap
« Risposta #61 il: Aprile 16, 2012, 08:28:46 pm »

http://00host.net/ questo è il server

un sms senza accentate viene consegnato regolarmente, invece il messaggio non viene consegnato se contiene una lettera accentata, per questo motivo ritengo che non funziona. Non so se la risposta di tutore faccia riferimento alle accentate, perchè checco987 ha chiesto se o2 funziona da web.

uso firefox, aspè che cambio browser. Non cambia nulla nemmeno con IE
« Ultima modifica: Aprile 16, 2012, 08:34:39 pm da drjis »
Connesso

glampunk

  • User terzo livello
  • ***
  • Karma: +1/-0
  • Offline Offline
  • Post: 139
    • Mostra profilo
Re:E fu cosi che arrivò anche la prima versione Web/Wap
« Risposta #62 il: Aprile 16, 2012, 08:50:21 pm »

a me funziona perfettamente con o2 (server hostoi) e caratteri accentati, sia web che wap. (e ne approfitto per fare i complimenti a Daniele)
Connesso

drjis

  • GoJack tester
  • User quarto livello
  • *****
  • Karma: +15/-0
  • Offline Offline
  • Post: 485
    • Mostra profilo
Re:E fu cosi che arrivò anche la prima versione Web/Wap
« Risposta #63 il: Aprile 16, 2012, 08:52:34 pm »

a te funziona? anche da android? ma le accentate dipendono anche da freesmee per caso?
Connesso

tutore91

  • Global Moderator
  • User quarto livello
  • *****
  • Karma: +22/-0
  • Offline Offline
  • Post: 345
  • Sarà leggen... adesso arriva... dario!
    • Mostra profilo
    • Belli e basta.
Re:E fu cosi che arrivò anche la prima versione Web/Wap
« Risposta #64 il: Aprile 16, 2012, 08:59:01 pm »

per caso c'erano dei punti di domanda sul messaggio?
Connesso

drjis

  • GoJack tester
  • User quarto livello
  • *****
  • Karma: +15/-0
  • Offline Offline
  • Post: 485
    • Mostra profilo
Re:E fu cosi che arrivò anche la prima versione Web/Wap
« Risposta #65 il: Aprile 16, 2012, 09:02:25 pm »

a me funziona perfettamente con o2 (server hostoi) e caratteri accentati, sia web che wap. (e ne approfitto per fare i complimenti a Daniele)

per favore puoi postare il sito del server?

nessun punto interrogativo
Connesso

Daniele8787

  • Sviluppatore GoJack
  • Administrator
  • Senior
  • *****
  • Karma: +95/-0
  • Offline Offline
  • Post: 1875
  • L'unica vera libertà, corrisponde al non aver bisogno di NULLA.
    • Mostra profilo
Re:E fu cosi che arrivò anche la prima versione Web/Wap
« Risposta #66 il: Aprile 16, 2012, 09:05:47 pm »

a te funziona? anche da android? ma le accentate dipendono anche da freesmee per caso?
No, non dipendono da freesmee. Semmai dipendono dall'xml, perchè per o2 vedo che è impostata la codifica utf-8 come in altri servizi che pare funzionino. Strano che te ne sei accorto soltanto ora...mi pare che prima con gojack inviavi correttamente con o2. E' da mesi che testiamo. Comunque prova con altro server, ad esempio horizon-host, webhost, o perchè no anche altervista e vedi se i problemi restano...perchè mi pare che prima inviavi correttamente con o2.

Altrimenti soluzione drastica: apri l'xml di o2 e dove dice output_encoding metti ACCENT al posto di utf-8 e cosi tutte le accentate verranno convertite in lettere normali.
Connesso

tutore91

  • Global Moderator
  • User quarto livello
  • *****
  • Karma: +22/-0
  • Offline Offline
  • Post: 345
  • Sarà leggen... adesso arriva... dario!
    • Mostra profilo
    • Belli e basta.
Re:E fu cosi che arrivò anche la prima versione Web/Wap
« Risposta #67 il: Aprile 16, 2012, 09:12:09 pm »

a me arrivano perfettamente, l'unica cosa è che nel php sotto i messaggi inviati vedo le accentate con simboli strani ma arrivano giuste
Connesso

drjis

  • GoJack tester
  • User quarto livello
  • *****
  • Karma: +15/-0
  • Offline Offline
  • Post: 485
    • Mostra profilo
Re:E fu cosi che arrivò anche la prima versione Web/Wap
« Risposta #68 il: Aprile 16, 2012, 09:28:24 pm »

io non sono mai riuscito ad inviare le accentate con gojack, già mesi fa avevo chiesto da cosa dipendevano le accentate e con l'ultimo aggiornamento l'ho segnalato di nuovo. Provo a fare ciò che mi hai consigliato, spero in bene
Connesso

tutore91

  • Global Moderator
  • User quarto livello
  • *****
  • Karma: +22/-0
  • Offline Offline
  • Post: 345
  • Sarà leggen... adesso arriva... dario!
    • Mostra profilo
    • Belli e basta.
Re:E fu cosi che arrivò anche la prima versione Web/Wap
« Risposta #69 il: Aprile 16, 2012, 09:32:32 pm »

altrimenti su output_encoding prova proprio a lasciare solo le "" senza scrivere niente e vedere se funziona
Connesso

Daniele8787

  • Sviluppatore GoJack
  • Administrator
  • Senior
  • *****
  • Karma: +95/-0
  • Offline Offline
  • Post: 1875
  • L'unica vera libertà, corrisponde al non aver bisogno di NULLA.
    • Mostra profilo
Re:E fu cosi che arrivò anche la prima versione Web/Wap
« Risposta #70 il: Aprile 16, 2012, 09:39:06 pm »

a me arrivano perfettamente, l'unica cosa è che nel php sotto i messaggi inviati vedo le accentate con simboli strani ma arrivano giuste
Si di questo me n'ero accorto e l'ho corretto nella nuova versione che sto per rilasciare di gojack.php.
Connesso

antonino.spampinato

  • User quarto livello
  • ****
  • Karma: +18/-1
  • Offline Offline
  • Post: 468
    • Mostra profilo
Re:E fu cosi che arrivò anche la prima versione Web/Wap
« Risposta #71 il: Aprile 17, 2012, 12:42:46 pm »

a me arrivano perfettamente, l'unica cosa è che nel php sotto i messaggi inviati vedo le accentate con simboli strani ma arrivano giuste
Ciò è normale, perché la web gojack usa CP-1252 conosciuto anche come WINDOWS-1252,prodotto con php ISO_8859_1 di default se non specificato diversamente.
Con un un utente agente (browser) compatibile CP-1252 non leggera mai da php i caratteri con codice esadecimale che non esiste, in quella codifica provenienti da diverse codifiche.
Es. se qualcuno o lo sviluppatore potrebbe testare a rischio di privacy il servizio O2 preventivamente modificando il modulo di gojackweb con method"get"..le variabili generate saranno già contenute nell'url. http://www.tuosito.com?variabile=valore&variabile=valore fino ad arrivare al corpo del messaggio ecc. convertito in esadecimale preceduto dal simbolo % già sarà convertito nella codifica espressa dall'output encoding del sevizio del file xml.
es. è=e8 esadecimale ISO_8859_1,è=c3 a8 esadecimale UTF-8.
« Ultima modifica: Aprile 17, 2012, 01:12:47 pm da antonino.spampinato »
Connesso

glampunk

  • User terzo livello
  • ***
  • Karma: +1/-0
  • Offline Offline
  • Post: 139
    • Mostra profilo
Re:E fu cosi che arrivò anche la prima versione Web/Wap
« Risposta #72 il: Aprile 17, 2012, 04:33:22 pm »

a me funziona perfettamente con o2 (server hostoi) e caratteri accentati, sia web che wap. (e ne approfitto per fare i complimenti a Daniele)

per favore puoi postare il sito del server?

nessun punto interrogativo

Il sito è http://www.000webhost.com/

ti darà un indirizzo miosito.hostoi.com

mi sono appena mandato un messaggio via Wap pieno di accenti, punti interrogativi ed esclamativi. E' arrivato! :)
Connesso

drjis

  • GoJack tester
  • User quarto livello
  • *****
  • Karma: +15/-0
  • Offline Offline
  • Post: 485
    • Mostra profilo
Re:E fu cosi che arrivò anche la prima versione Web/Wap
« Risposta #73 il: Aprile 17, 2012, 09:27:58 pm »

con questo sito hosting ho risolto 8) è strano che con il mio non funziona, posso dire che o2 funziona perfettamente
Connesso

Daniele8787

  • Sviluppatore GoJack
  • Administrator
  • Senior
  • *****
  • Karma: +95/-0
  • Offline Offline
  • Post: 1875
  • L'unica vera libertà, corrisponde al non aver bisogno di NULLA.
    • Mostra profilo
Re:E fu cosi che arrivò anche la prima versione Web/Wap
« Risposta #74 il: Aprile 17, 2012, 10:33:55 pm »

Il problema del servizio che si seleziona da solo è rimasto invece?
Connesso
Pagine: 1 ... 3 4 [5] 6 7 ... 9   Vai su
 

Contatta Daniele8787 l'autore di GoJack


Se vuoi ringraziare me (Daniele8787) e ciopper90, per il lavoro svolto fin'ora,
puoi prendere in considerazione una libera donazione. Grazie mille.